Standard

IEEE 9274.1.1-2023

Actuel

Amendements et versions existants ou nouveaux doivent être achetés séparément.

Langue
Format

Achat d'une licence utilisateur unique

Reproduction interdite. Veuillez nous contacter pour des informations sur les licences.

Bénéficiez d'une remise de 20 % pour les nouveaux clients sur les abonnements aux normes SNV et les licences multi-utilisateurs.

Résumé

New IEEE Standard - Active. This standard is a collaborative effort to improve and standardize the 1.0.3 version Experience Application Programming Interface (xAPI) specification. This Standard describes a JavaScript Object Notation (JSON) data model format and a Representational State Transfer (RESTful) Web Service Application Programming Interface (API) for communication between Activities experienced by an individual, group, or other entity and a Learning Record Store (LRS). The LRS is a system that exposes the RESTful Web Service API for the purpose of tracking and accessing experiential data, especially in learning and human performance.

Spécifications des produits

  • Standard de IEEE
  • Publié:
  • Type de document: IS
  • Editeur: IEEE
  • Distributeur: IEEE
  • ICS: 35.240.90
  • ICS: 35.240.95
  • Comité national: IEEE Computer Society / Learning Technology

Relations produit

  • Référence: IEEE 754-2019
  • Référence: IETF RFC 7231, Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content.
  • Référence: IETF RFC 7515, JSON Web Signature (JWS).
  • Référence: ISO 8601, Date and time--Representations for information interchange.
  • Référence: IETF RFC 5646, Tags for Identifying Languages.
  • Référence: FIPS PUB 180-2, Secure Hash Signature Standard (SHA2).
  • Référence: ISO 639, Code for the Representation of Names of Languages.
  • Référence: ISO 3166-1, Codes for the Representation of Names of Countries and Their Subdivisions--Part 1: Country Codes.
  • Référence: IETF RFC 3629, UTF-8, A Transformation Format of ISO 10646.
  • Référence: IETF RFC 8259, The JavaScript Object Notation (JSON) Data Interchange Format.
  • Référence: IETF RFC 2046, Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types.
  • Référence: IETF RFC 3987, Internationalized Resource Identifiers (IRIs).
  • Référence: IETF RFC 4122, A Universally Unique IDentifier (UUID) URN Namespace (IRIs).
  • Référence: IETF RFC 2616, Hypertext Transfer Protocol -- HTTP/1.1.